Comments on YouTube Videos
Incident Report for Talis
Resolved
This incident has been resolved.
Posted Feb 07, 2020 - 16:45 UTC
Investigating
We are aware of an issue with leaving comments on YouTube videos within Talis Elevate and are currently investigating.
Posted Feb 07, 2020 - 14:44 UTC
This incident affected: Elevate (General).