Login issue
Incident Report for Technology from SAGE
Resolved
We are confident this issue has been resolved, apologies for any impact on your day. Do let us know via a support ticket if you experience any other issues.
Posted Aug 24, 2021 - 08:43 UTC
Update
We are continuing to investigate this issue.
Posted Aug 24, 2021 - 08:14 UTC
Investigating
We are currently investigating an urgent issue with login into Talis Aspire which is affecting all reading list and Copyright Clearance tenancies in our Europe and APAC. We will work to keep you updated.
Posted Aug 24, 2021 - 08:14 UTC
This incident affected: Talis Aspire Reading Lists (Login).