Reviews delayed in the Processing status
Incident Report for Technology from SAGE
Resolved
This incident has been resolved.
Posted Oct 13, 2021 - 14:34 UTC
Investigating
We are currently investigating with a high-priority issue relating to Reviews within Talis Aspire. Currently, there are delays in the processing status and stages of reviews. This is for our APAC and Europe universities.

We will work to keep you updated as we gather more information on this issue.
Posted Oct 13, 2021 - 12:57 UTC
This incident affected: Talis Aspire Reading Lists (Reviews).