TALIS ELEVATE and TALIS REVIEWS: login and usage
Incident Report for Technology from SAGE
Resolved
We believe this issue is now resolved, and we are continuing to monitor the affected services.
Posted Jul 13, 2021 - 11:14 UTC
Update
We believe this issue is now resolved, and we are continuing to monitor the affected services.
Posted Jul 13, 2021 - 11:12 UTC
Update
We are continuing to investigate this issue.
Posted Jul 13, 2021 - 10:41 UTC
Investigating
We are currently investigating this issue.
Posted Jul 13, 2021 - 10:38 UTC
This incident affected: Talis Elevate (General) and Talis Aspire Reading Lists (Reviews).