Error on downloading digitisation bundles
Incident Report for Talis
Resolved
This issue is now resolved, apologies for any inconvenience caused.
Posted Nov 10, 2020 - 13:50 UTC
Investigating
We are currently investigating an issue where digitisation bundles are unable to be downloaded. We will work to keep you updated as our team investigates this as an urgent priority.
Posted Nov 10, 2020 - 13:48 UTC
This incident affected: Digitised Content (General).