Reviews access
Incident Report for Technology from SAGE
Resolved
Access to Reviews in Talis Aspire has been resolved. We do apologise for any inconvenience at this time.
Posted Jun 14, 2022 - 14:12 UTC
Investigating
We are currently investigating an issue with access to our Reviews interface. Our team are working on this with an urgent priority, we will work to keep you updated.
Posted Jun 14, 2022 - 13:13 UTC
This incident affected: Talis Aspire Reading Lists (Reviews).